summaryrefslogtreecommitdiffstats
path: root/doc/c/xml/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-17 17:45:43 -0400
committerDavid Robillard <d@drobilla.net>2022-07-18 21:06:35 -0400
commit68293752dbfd80016dc7543b88f22c602427fa75 (patch)
tree4c3e93bb6f345de27e0e8b7403fea50d54639ff8 /doc/c/xml/meson.build
parent0d018befdaa9b59ddcc53d21b01bef1439a237e3 (diff)
downloadsuil-68293752dbfd80016dc7543b88f22c602427fa75.tar.gz
suil-68293752dbfd80016dc7543b88f22c602427fa75.tar.bz2
suil-68293752dbfd80016dc7543b88f22c602427fa75.zip
Switch to meson build system
Diffstat (limited to 'doc/c/xml/meson.build')
-rw-r--r--doc/c/xml/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/c/xml/meson.build b/doc/c/xml/meson.build
new file mode 100644
index 0000000..c6c454e
--- /dev/null
+++ b/doc/c/xml/meson.build
@@ -0,0 +1,18 @@
+doxygen = find_program('doxygen')
+
+config = configuration_data()
+config.set('SUIL_SRCDIR', suil_src_root)
+config.set('DOX_OUTPUT', meson.current_build_dir() / '..')
+
+c_doxyfile = configure_file(
+ configuration: config,
+ input: files('../Doxyfile.in'),
+ output: 'Doxyfile',
+)
+
+c_index_xml = custom_target(
+ 'index.xml',
+ command: [doxygen, '@INPUT0@'],
+ input: [c_doxyfile] + c_headers,
+ output: 'index.xml',
+)