summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-17 17:45:43 -0400
committerDavid Robillard <d@drobilla.net>2022-07-18 21:06:35 -0400
commit68293752dbfd80016dc7543b88f22c602427fa75 (patch)
tree4c3e93bb6f345de27e0e8b7403fea50d54639ff8 /doc/meson.build
parent0d018befdaa9b59ddcc53d21b01bef1439a237e3 (diff)
downloadsuil-68293752dbfd80016dc7543b88f22c602427fa75.tar.gz
suil-68293752dbfd80016dc7543b88f22c602427fa75.tar.bz2
suil-68293752dbfd80016dc7543b88f22c602427fa75.zip
Switch to meson build system
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 0000000..46fc3bb
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,15 @@
+docdir = get_option('datadir') / 'doc'
+
+doxygen = find_program('doxygen', required: get_option('docs'))
+dox_to_sphinx = files('../scripts/dox_to_sphinx.py')
+sphinx_build = find_program('sphinx-build', required: get_option('docs'))
+
+build_docs = doxygen.found() and sphinx_build.found()
+
+if build_docs
+ subdir('c')
+endif
+
+if not meson.is_subproject()
+ summary('Documentation', build_docs, bool_yn: true)
+endif