summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2025-01-20 13:08:08 -0500
committerDavid Robillard <d@drobilla.net>2025-01-20 13:08:08 -0500
commitfd11071115664d7cd72556c91e28cccf22c57bf5 (patch)
treec84013b4899032b0530cba903f45d8fb3f2591c6 /meson.build
parentf4240a9b27e98c40138c6ec866132b237f311dff (diff)
downloadsuil-fd11071115664d7cd72556c91e28cccf22c57bf5.tar.gz
suil-fd11071115664d7cd72556c91e28cccf22c57bf5.tar.bz2
suil-fd11071115664d7cd72556c91e28cccf22c57bf5.zip
Use "system" include type for all dependencies and add header test
Things get confused when these flags differ across projects, so universally use "system" for external dependencies and test for header warnings only in the project that owns them.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 16 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 3ededac..e785109 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 David Robillard <d@drobilla.net>
+# Copyright 2021-2025 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
project(
@@ -12,7 +12,7 @@ project(
],
license: 'ISC',
meson_version: '>= 0.56.0',
- version: '0.10.22',
+ version: '0.10.23',
)
suil_src_root = meson.current_source_dir()
@@ -203,7 +203,12 @@ endif
dl_dep = cc.find_library('dl', required: false)
-lv2_dep = dependency('lv2', fallback: 'lv2', version: '>= 1.18.4')
+lv2_dep = dependency(
+ 'lv2',
+ fallback: 'lv2',
+ include_type: 'system',
+ version: '>= 1.18.4',
+)
x11_dep = dependency(
'x11',
@@ -466,6 +471,14 @@ if qt6_dep.found()
)
endif
+#########
+# Tests #
+#########
+
+if not get_option('tests').disabled()
+ subdir('test/headers')
+endif
+
########
# Lint #
########