summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 12 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0d3c894..35bf462 100644
--- a/meson.build
+++ b/meson.build
@@ -49,6 +49,16 @@ platform_defines = ['-DSUIL_MODULE_DIR="@0@"'.format(suil_abs_module_dir)]
nodelete_c_link_args = cc.get_supported_link_arguments(['-Wl,-z,nodelete'])
nodelete_cpp_link_args = cpp.get_supported_link_arguments(['-Wl,-z,nodelete'])
+# Use versioned name everywhere to support parallel major version installations
+if host_machine.system() == 'windows'
+ if get_option('default_library') == 'both'
+ error('default_library=both is not supported on Windows')
+ endif
+ soversion = ''
+else
+ soversion = meson.project_version().split('.')[0]
+endif
+
################
# Dependencies #
################
@@ -132,20 +142,20 @@ sources = files(
# Set appropriate arguments for building against the library type
extra_c_args = []
-subdir('meson/library')
if get_option('default_library') == 'static'
extra_c_args = ['-DSUIL_STATIC']
endif
# Build shared and/or static library
libsuil = library(
- meson.project_name() + library_suffix,
+ versioned_name,
sources,
c_args: c_suppressions + extra_c_args + platform_defines + ['-DSUIL_INTERNAL'],
dependencies: [dl_dep, lv2_dep],
gnu_symbol_visibility: 'hidden',
include_directories: include_dirs,
install: true,
+ soversion: soversion,
version: meson.project_version(),
)