aboutsummaryrefslogtreecommitdiffstats
path: root/tools/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-11-07 06:30:02 -0500
committerDavid Robillard <d@drobilla.net>2022-11-07 06:56:07 -0500
commit036c4c1634b2e056da722b21302608ccfe05a298 (patch)
tree75e4a59b169f8012ec542c1fe806224bd5dc08ac /tools/meson.build
parentc002ebc4245e805d7a2a0ddaf2fd9f6ff58d22a4 (diff)
downloadchilbert-036c4c1634b2e056da722b21302608ccfe05a298.tar.gz
chilbert-036c4c1634b2e056da722b21302608ccfe05a298.tar.bz2
chilbert-036c4c1634b2e056da722b21302608ccfe05a298.zip
Build tools
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/meson.build b/tools/meson.build
new file mode 100644
index 0000000..1a12aba
--- /dev/null
+++ b/tools/meson.build
@@ -0,0 +1,15 @@
+# Copyright 2019-2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR GPL-2.0-or-later
+
+tools = [
+ 'chilbert_obj',
+ 'chilbert_svg',
+]
+
+foreach tool : tools
+ executable(
+ tool,
+ files('@0@.cpp'.format(tool)),
+ dependencies: [chilbert_dep],
+ )
+endforeach