aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 52b9012..ccbac27 100644
--- a/meson.build
+++ b/meson.build
@@ -54,6 +54,14 @@ elif cpp.get_id() == 'gcc'
endif
elif cpp.get_id() == 'msvc'
+ cpp_suppressions += [
+ '/experimental:external',
+ '/external:W0',
+ '/external:anglebrackets',
+
+ '/wd4146', # unary minus operator applied to unsigned type
+ ]
+
if warning_level == 'everything'
cpp_suppressions += [
'/wd4028', # formal parameter different from declaration
@@ -65,6 +73,24 @@ elif cpp.get_id() == 'msvc'
'/wd4711', # function selected for automatic inline expansion
'/wd4820', # padding added after construct
'/wd5045', # will insert Spectre mitigation
+
+ '/wd4625', # copy constructor implicitly deleted
+ '/wd4626', # assignment operator implicitly deleted
+ '/wd5026', # move constructor implicitly deleted
+ '/wd5027', # move assignment operator implicitly deleted
+ '/wd5246', # subobject should be wrapped in braces
+ ]
+ endif
+
+ if warning_level in ['everything', '3']
+ cpp_suppressions += [
+ '/wd4127', # conditional expression is constant
+ ]
+ endif
+
+ if warning_level in ['everything', '3', '2', '1']
+ cpp_suppressions += [
+ '/wd4146', # unary minus operator applied to unsigned type
]
endif
endif