summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorZeeshan Ali <zeenix@gmail.com>2003-01-30 20:24:26 +0000
committerZeeshan Ali <zeenix@gmail.com>2003-01-30 20:24:26 +0000
commit1c6ceb5c0bc0e572a47e0889818d06ea54365355 (patch)
treeb6614304f5c72b05a5654e75ae76a0c476539400 /configure.ac
parent0d1b9d28becf937c3514ad1d79f8736d0741991e (diff)
downloadgst-plugins-bad-1c6ceb5c0bc0e572a47e0889818d06ea54365355.tar.gz
gst-plugins-bad-1c6ceb5c0bc0e572a47e0889818d06ea54365355.tar.bz2
gst-plugins-bad-1c6ceb5c0bc0e572a47e0889818d06ea54365355.zip
The first attempt to support MAS. Dont expect it to work :)
Original commit message from CVS: The first attempt to support MAS. Dont expect it to work :)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 675d17bf..4ae65d84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -497,6 +497,15 @@ GST_CHECK_FEATURE(DVDNAV, [dvdnav library], dvdnavsrc, [
AS_SCRUB_INCLUDE(DVDNAV_CFLAGS)
])
+dnl *** MAS ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_MAS, true)
+GST_CHECK_FEATURE(MAS, [mas library], massink, [
+ translit(dnm, m, l) AC_SUBST(MAS_LIBS)
+ translit(dnm, m, l) AC_SUBST(MAS_CFLAGS)
+ GST_CHECK_CONFIGPROG(MAS, mas-config)
+ AS_SCRUB_INCLUDE(MAS_CFLAGS)
+])
+
dnl **** ESound ****
translit(dnm, m, l) AM_CONDITIONAL(USE_ESD, true)
GST_CHECK_FEATURE(ESD, [esound plug-ins], esdsink esdmon, [
@@ -1097,6 +1106,7 @@ ext/lcs/Makefile
ext/libfame/Makefile
ext/libpng/Makefile
ext/mad/Makefile
+ext/mas/Makefile
ext/mikmod/Makefile
ext/mjpegtools/Makefile
ext/mpeg2dec/Makefile