summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-06-04 15:54:58 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-06-04 15:54:58 +0000
commit3115f532f420fe3e60432a8145118055233b3caa (patch)
tree2e88ba613327be7ca0f38c0a1a8e8b8942cf3800 /configure.ac
parent7523a7139a28462f59b80a97ff8a12b59f88a30b (diff)
downloadgst-plugins-bad-3115f532f420fe3e60432a8145118055233b3caa.tar.gz
gst-plugins-bad-3115f532f420fe3e60432a8145118055233b3caa.tar.bz2
gst-plugins-bad-3115f532f420fe3e60432a8145118055233b3caa.zip
doing the proper ladspa thing
Original commit message from CVS: doing the proper ladspa thing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5a932f4d..64e3664b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -472,10 +472,16 @@ GST_CHECK_FEATURE(JPEG, [jpeg], jpegenc jpegdec, [
AC_SUBST(JPEG_LIBS)
])
+dnl *** ladspa ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_LADSPA, true)
+GST_CHECK_FEATURE(LADSPA, [ladspa], ladspa, [
+ AC_CHECK_HEADER(ladspa.h, HAVE_LADSPA="yes", HAVE_LADSPA="no")
+])
+
dnl *** lame ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LAME, true)
GST_CHECK_FEATURE(LAME, [lame mp3 encoder library], lame, [
-GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h, HAVE_LAME="yes" LAME_LIBS="-lmp3lame")
+ GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h, HAVE_LAME="yes" LAME_LIBS="-lmp3lame")
])
AC_SUBST(LAME_LIBS)