summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2002-09-15 21:33:53 +0000
committerDavid Schleef <ds@schleef.org>2002-09-15 21:33:53 +0000
commit7e744852997c7c0bc777ca586f8cc85467fe8ffd (patch)
treed46c8d9bdf045a981fa3ad7504af420d0e375ef4 /configure.ac
parenta060de748e51f5105151374db44b802ea78709ff (diff)
downloadgst-plugins-bad-7e744852997c7c0bc777ca586f8cc85467fe8ffd.tar.gz
gst-plugins-bad-7e744852997c7c0bc777ca586f8cc85467fe8ffd.tar.bz2
gst-plugins-bad-7e744852997c7c0bc777ca586f8cc85467fe8ffd.zip
Add swfdec autoconf stuff
Original commit message from CVS: Add swfdec autoconf stuff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 998b729b..859f2a69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -741,6 +741,14 @@ GST_CHECK_FEATURE(LIBPNG, [snapshot plug-in], snapshot, [
AC_SUBST(LIBPNG_LIBS)
])
+dnl *** swfdec ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SWFDEC, true)
+GST_CHECK_FEATURE(SWFDEC, [swfdec plug-in], swfdec, [
+ PKG_CHECK_MODULES(SWFDEC, libswfdec, HAVE_SWFDEC="yes", HAVE_SWFDEC="no")
+ AC_SUBST(SWFDEC_CFLAGS)
+ AC_SUBST(SWFDEC_LIBS)
+])
+
dnl *** tarkin ***
dnl for now the sources are included in the plug-in
dnl and should be moved to ext-libs/ perhaps
@@ -1019,6 +1027,7 @@ ext/sdl/Makefile
ext/shout/Makefile
ext/sidplay/Makefile
ext/smoothwave/Makefile
+ext/swfdec/Makefile
ext/vorbis/Makefile
ext/tarkin/Makefile
ext/xmms/Makefile