summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-01-03 18:12:13 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-01-03 18:12:13 +0000
commit9228f860461b34426f61bd8fcaba5941f8449db5 (patch)
tree0f9c21a4718007f5585cc3fa6855fb0be8bd0dee /configure.ac
parent6378387cb7d64323f23eafb468d868fd63a021e1 (diff)
downloadgst-plugins-bad-9228f860461b34426f61bd8fcaba5941f8449db5.tar.gz
gst-plugins-bad-9228f860461b34426f61bd8fcaba5941f8449db5.tar.bz2
gst-plugins-bad-9228f860461b34426f61bd8fcaba5941f8449db5.zip
adding sidplay and festival "checks"
Original commit message from CVS: adding sidplay and festival "checks"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 24 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0fd2bd1b..67155828 100644
--- a/configure.ac
+++ b/configure.ac
@@ -341,6 +341,14 @@ GST_CHECK_FEATURE(ALSA, [alsa plugins], gstalsa, [
])
dnl *** arts ***
+
+dnl if mcopidl can't be found there's no use in compiling it
+AC_CHECK_PROG(MCOPIDL, mcopidl, yes, no)
+if test "xHAVE_MCOPIDL" = "xno";
+then
+ USE_ARTS=no
+fi
+
translit(dnm, m, l) AM_CONDITIONAL(USE_ARTS, true)
GST_CHECK_FEATURE(ARTS, [arts plugins], arts, [
AM_PATH_ARTS(, HAVE_ARTS=yes, HAVE_ARTS=no)
@@ -410,6 +418,14 @@ GST_CHECK_FEATURE(ESD, [esound plugins], esdsrc esdsink, [
AM_PATH_ESD(0.2.12, HAVE_ESD=yes, HAVE_ESD=no)
])
+dnl **** festival ****
+dnl FIXME until thomas can be bothered to download the 20 MB festival sources
+dnl this will not go in
+translit(dnm, m, l) AM_CONDITIONAL(USE_FESTIVAL, true)
+GST_CHECK_FEATURE(FESTIVAL, [festival plugins], festivalsink, [
+ HAVE_FESTIVAL=no
+])
+
dnl *** FLAC ***
dnl thomas : checking for compile with main instead of actual function,
dnl since that made autoconf break (for version 2.13)
@@ -549,17 +565,20 @@ GST_CHECK_FEATURE(SHOUT, [shout plugin], icecastsend, [
AC_SUBST(SHOUT_LIBS)
])
+dnl *** sidplay ***
+dnl FIXME : make this work
+translit(dnm, m, l) AM_CONDITIONAL(USE_SIDPLAY, true)
+GST_CHECK_FEATURE(SIDPLAY, [sidplay plugin], sidplay, [
+ GST_CHECK_LIBHEADER(SIDPLAY, sidplay, sidTune(), ,sidplay/sidtune.h,SIDPLAY_LIBS="-lsidplay")
+ AC_SUBST(SIDPLAY_LIBS)
+])
+
dnl *** smoothwave ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SMOOTHWAVE, true)
GST_CHECK_FEATURE(SMOOTHWAVE, [smoothwave plugin], smoothwave, [
if test $HAVE_GTK = "yes"; then HAVE_SMOOTHWAVE=yes; fi;
])
-dnl for sidplay
-dnl FIXME : make this work
-dnl AC_PATH_LIBSIDPLAY
-
-
dnl *** vorbis ***
dnl AM_PATH_VORBIS only takes two options
translit(dnm, m, l) AM_CONDITIONAL(USE_VORBIS, true)