summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-21 21:54:27 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-21 21:54:27 +0000
commitab57fbcd544e5226cb57aef7d54370f58e8badf4 (patch)
treec6f10a198cf57b4279b82ecb41069f66fd13ee9e /configure.ac
parent7ca8563737c8a87cdd54bb2aefe8321354c5362e (diff)
downloadgst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.tar.gz
gst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.tar.bz2
gst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.zip
Adds divx/xvid encoders. divx encoder is based on divx4linux (commercial, closed-source)
Original commit message from CVS: Adds divx/xvid encoders. * divx encoder is based on divx4linux (commercial, closed-source) * xvid encoder is based on xvidcore (http://www.xvid.org/, GPL - Christian? ;) ) Both use a GstCaps that doesn't conform with what we currently use, I might fix that later on or so. For now, it doesn't matter, it's just a test. We're also missing corresponding decoders (ffmpeg can decoded this too, but that's not the point), these might come later too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9401d1e..c88fb58f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -506,6 +506,21 @@ dnl FIXME : add second check somehow if that is necessary
dnl AC_CHECK_LIB(cdda_paranoia, paranoia_init, : , HAVE_CDPARANOIA=no, -lcdda_interface )
dnl AC_CHECK_HEADER(cdda_paranoia.h, :, HAVE_CDPARANOIA=no)
+dnl *** DIVX ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIVX, true)
+GST_CHECK_FEATURE(DIVX, [divx plugins], divx, [
+ HAVE_DIVX=yes
+ AC_CHECK_HEADER(encore2.h, ,
+ [ AC_MSG_WARN([Divx4linux headers not found]) &&
+ HAVE_DIVX=no ] )
+ LIBS="-lm"
+ AC_CHECK_LIB(divxencore, encore, ,
+ [ AC_MSG_WARN([Divx4linux libs not found]) &&
+ HAVE_DIVX=no ] )
+ DIVX_LIBS="-lxvidcore -lm"
+ AC_SUBST(DIVX_LIBS)
+])
+
dnl *** dvdread ***
translit(dnm, m, l) AM_CONDITIONAL(USE_DVDREAD, true)
GST_CHECK_FEATURE(DVDREAD, [dvdread library], dvdreadsrc, [
@@ -875,6 +890,22 @@ GST_CHECK_FEATURE(XMMS, [xmms plug-in], xmms, [
AM_PATH_XMMS(0.1.0, HAVE_XMMS=yes, HAVE_XMMS=no)
])
+dnl *** XVID ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_XVID, true)
+GST_CHECK_FEATURE(XVID, [xvid plugins], xvid, [
+ HAVE_XVID=yes
+ AC_CHECK_HEADER(xvid.h, ,
+ [ AC_MSG_WARN([Xvid headers not found]) &&
+ HAVE_XVID=no ] )
+ LIBS="-lm"
+ AC_CHECK_LIB(xvidcore, xvid_encore, ,
+ [ AC_MSG_WARN([Xvid libs not found]) &&
+ HAVE_XVID=no ] )
+ XVID_LIBS="-lxvidcore -lm"
+ AC_SUBST(XVID_LIBS)
+])
+
+
fi dnl of EXT plugins
dnl Check for atomic.h
@@ -1127,6 +1158,7 @@ ext/artsd/Makefile
ext/audiofile/Makefile
ext/avifile/Makefile
ext/cdparanoia/Makefile
+ext/divx/Makefile
ext/dv/Makefile
ext/dvdread/Makefile
ext/dvdnav/Makefile
@@ -1162,6 +1194,7 @@ ext/swfdec/Makefile
ext/vorbis/Makefile
ext/tarkin/Makefile
ext/xmms/Makefile
+ext/xvid/Makefile
gst-libs/Makefile
gst-libs/gst/Makefile
gst-libs/gst/audio/Makefile