summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-12-26 10:53:21 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-12-26 10:53:21 +0000
commite947d5f47236746e43d2661a51b8eeb08b3b45a2 (patch)
treed754992d82cac3e0a3e558440be5295c96f1a0ce /configure.ac
parent0ecc91bfd8e00a14dac91b9ff44197a563e7c30a (diff)
downloadgst-plugins-bad-e947d5f47236746e43d2661a51b8eeb08b3b45a2.tar.gz
gst-plugins-bad-e947d5f47236746e43d2661a51b8eeb08b3b45a2.tar.bz2
gst-plugins-bad-e947d5f47236746e43d2661a51b8eeb08b3b45a2.zip
slurp in ffmpeg a) please test b) please help me figure out how to portably link in a .a file in our .so plugin
Original commit message from CVS: slurp in ffmpeg a) please test b) please help me figure out how to portably link in a .a file in our .so plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2b635c6c..6520a47a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,6 +207,7 @@ GTK_LIBS=$GTK2_LIBS
AC_SUBST(GTK_LIBS)
AC_SUBST(GTK_CFLAGS)
+
dnl Check for X11 extensions
AC_PATH_XTRA
if test "-DX_DISPLAY_MISSING" = "$X_CFLAGS"; then
@@ -522,7 +523,10 @@ GST_CHECK_FEATURE(FLAC, [FLAC lossless audio], flacenc flacdec, [
dnl *** FFMPEG ***
translit(dnm, m, l) AM_CONDITIONAL(USE_FFMPEG, true)
GST_CHECK_FEATURE(FFMPEG, [ffmpeg plug-ins], ffmpeg, [
- AM_PATH_FFMPEG(0.4.6, HAVE_FFMPEG=yes, HAVE_FFMPEG=no)
+ AS_SLURP_FFMPEG(gst-libs/ext/ffmpeg, "2002-12-14 12:00 GMT",
+ HAVE_FFMPEG=yes, HAVE_FFMPEG=no)
+ AC_DEFINE_UNQUOTED(HAVE_FFMPEG_UNINSTALLED, 1,
+ [defined if we use uninstalled ffmpeg])
])
dnl *** Gnome VFS ***
@@ -1089,6 +1093,8 @@ gst-libs/gst/play/Makefile
gst-libs/gst/resample/Makefile
gst-libs/gst/riff/Makefile
gst-libs/gst/video/Makefile
+gst-libs/ext/Makefile
+gst-libs/ext/ffmpeg/Makefile
examples/dynparams/Makefile
examples/capsfilter/Makefile
examples/seeking/Makefile
@@ -1100,7 +1106,6 @@ testsuite/Makefile
tools/Makefile
gconf/Makefile
)
-
AC_OUTPUT
echo -e "configure: *** Plug-ins that will be built : $GST_PLUGINS_YES"