summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-08-13 11:56:57 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-08-13 11:56:57 +0000
commitfdca2dc12c1d7922de6ea0383074730041eb3896 (patch)
tree29c06982e68a02c425863f2fdf2d23699889da19 /configure.ac
parent5a678384d2ebafdf7bb8b4bf5edf6d03d61581ba (diff)
downloadgst-plugins-bad-fdca2dc12c1d7922de6ea0383074730041eb3896.tar.gz
gst-plugins-bad-fdca2dc12c1d7922de6ea0383074730041eb3896.tar.bz2
gst-plugins-bad-fdca2dc12c1d7922de6ea0383074730041eb3896.zip
also adding a libstdc++ check explicitly
Original commit message from CVS: also adding a libstdc++ check explicitly
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 76f7513a..80115d93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -412,8 +412,18 @@ GST_CHECK_FEATURE(AUDIOFILE, [audiofile], afsink afsrc, [
dnl *** avifile ***
translit(dnm, m, l) AM_CONDITIONAL(USE_AVIFILE, true)
GST_CHECK_FEATURE(AVIFILE, [avifile], winenc windec, [
- if test "x$HAVE_CXX" = "xyes"; then
- AS_AVIFILE(0.7.0)
+ if test "x$HAVE_CXX" != "xyes"; then
+ AC_MSG_WARN(No C++ compiler found, not compiling avifile plug-ins)
+ HAVE_AVIFILE="no"
+ else
+ dnl check for libstdc++
+ AC_CHECK_LIB(stdc++, cout,
+ [AS_AVIFILE(0.7.0)],
+ [
+ AC_MSG_WARN(You need libstdc++ to compile with avifile)
+ HAVE_AVIFILE="no"
+ ]
+ )
fi
])