summaryrefslogtreecommitdiffstats
path: root/debian/mk.control
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2002-09-20 04:02:59 +0000
committerDavid Schleef <ds@schleef.org>2002-09-20 04:02:59 +0000
commit91b9c6c9c66c9a2df62595224d7d1fc9e39db414 (patch)
tree648d3b8d52c0e83ca74710a31b596858f44b3e71 /debian/mk.control
parent04d121885acc1e64b796672f4d6cc4ed000a662d (diff)
downloadgst-plugins-bad-91b9c6c9c66c9a2df62595224d7d1fc9e39db414.tar.gz
gst-plugins-bad-91b9c6c9c66c9a2df62595224d7d1fc9e39db414.tar.bz2
gst-plugins-bad-91b9c6c9c66c9a2df62595224d7d1fc9e39db414.zip
gstreamer-gconf.files: libgstgconf.so moved to /usr/lib added control.in, build-deps, and mk.control script. Edit co...
Original commit message from CVS: * gstreamer-gconf.files: libgstgconf.so moved to /usr/lib * added control.in, build-deps, and mk.control script. Edit control.in and/or build-deps, and run 'debian/rules debian/control' from toplevel directory to recreate debian/control. This should make it a lot easier to diff build dependencies.
Diffstat (limited to 'debian/mk.control')
-rwxr-xr-xdebian/mk.control17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/mk.control b/debian/mk.control
new file mode 100755
index 00000000..f9251402
--- /dev/null
+++ b/debian/mk.control
@@ -0,0 +1,17 @@
+#!/usr/bin/perl -w
+
+
+open BUILDDEPS, "debian/build-deps";
+@builddeplist = <BUILDDEPS>;
+close BUILDDEPS;
+
+chomp(@builddeplist);
+$builddeps = join(", ", @builddeplist);
+
+open CONTROLIN, "debian/control.in";
+
+while(<CONTROLIN>){
+ s/BUILDDEPS/$builddeps/;
+ print;
+}
+