summaryrefslogtreecommitdiffstats
path: root/gconf/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-02-23 22:31:48 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-02-23 22:31:48 +0000
commit98b68da0a8e990aa2e5529ef5894c326962c05e0 (patch)
tree6e0bdf119e7e024c054fdfa16181a88f064039bf /gconf/Makefile.am
parent47c01dd0989e38939ee7aa7e19dfcbbefe93a228 (diff)
downloadgst-plugins-bad-98b68da0a8e990aa2e5529ef5894c326962c05e0.tar.gz
gst-plugins-bad-98b68da0a8e990aa2e5529ef5894c326962c05e0.tar.bz2
gst-plugins-bad-98b68da0a8e990aa2e5529ef5894c326962c05e0.zip
versioning gstreamer schemas and install location
Original commit message from CVS: versioning gstreamer schemas and install location
Diffstat (limited to 'gconf/Makefile.am')
-rw-r--r--gconf/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/gconf/Makefile.am b/gconf/Makefile.am
index b3ca1fad..8fa37fbc 100644
--- a/gconf/Makefile.am
+++ b/gconf/Makefile.am
@@ -1,5 +1,8 @@
schemadir = @GCONF_SCHEMA_FILE_DIR@
-schema_DATA = gstreamer.schemas
+schema_DATA = gstreamer-@GST_MAJORMINOR@.schemas
+
+gstreamer-@GST_MAJORMINOR@.schemas: gstreamer.schemas
+ cp $< $@
install-data-local:
@GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) \
@@ -10,4 +13,5 @@ install-data-local:
echo "*****************************************************";)
@true
-EXTRA_DIST = gstreamer.schemas
+CLEANFILES = $(schema_DATA)
+EXTRA_DIST = $(schema_DATA)