summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/colorbalance/Makefile.am
diff options
context:
space:
mode:
authorDavid I. Lehn <dlehn@users.sourceforge.net>2004-02-03 08:56:06 +0000
committerDavid I. Lehn <dlehn@users.sourceforge.net>2004-02-03 08:56:06 +0000
commit85e7b51cf2138f272a0fb5c8083bc044c50327b9 (patch)
tree1f558d97fac5d44e2691590cdac26dc0c549b7ac /gst-libs/gst/colorbalance/Makefile.am
parent0724b6808fdb8a5d9296b476aef3e1a6b1026b9b (diff)
downloadgst-plugins-bad-85e7b51cf2138f272a0fb5c8083bc044c50327b9.tar.gz
gst-plugins-bad-85e7b51cf2138f272a0fb5c8083bc044c50327b9.tar.bz2
gst-plugins-bad-85e7b51cf2138f272a0fb5c8083bc044c50327b9.zip
gst-libs/gst/: Generate enum type code with glib-mkenums.
Original commit message from CVS: * gst-libs/gst/colorbalance/Makefile.am: * gst-libs/gst/colorbalance/colorbalance.h: * gst-libs/gst/mixer/Makefile.am: * gst-libs/gst/mixer/mixer.h: * gst-libs/gst/play/Makefile.am: * gst-libs/gst/play/play.h: * gst-libs/gst/tuner/Makefile.am: * gst-libs/gst/tuner/tuner.h: Generate enum type code with glib-mkenums. * gst-libs/gst/colorbalance/.cvsignore: * gst-libs/gst/mixer/.cvsignore: * gst-libs/gst/play/.cvsignore: * gst-libs/gst/tuner/.cvsignore: Ignore generated files.
Diffstat (limited to 'gst-libs/gst/colorbalance/Makefile.am')
-rw-r--r--gst-libs/gst/colorbalance/Makefile.am34
1 files changed, 29 insertions, 5 deletions
diff --git a/gst-libs/gst/colorbalance/Makefile.am b/gst-libs/gst/colorbalance/Makefile.am
index a86319c2..d2aee92c 100644
--- a/gst-libs/gst/colorbalance/Makefile.am
+++ b/gst-libs/gst/colorbalance/Makefile.am
@@ -1,23 +1,30 @@
libgstcolorbalanceincludedir = \
$(includedir)/gstreamer-@GST_MAJORMINOR@/gst/colorbalance
-libgstcolorbalanceinclude_HEADERS = \
+colorbalance_headers = \
colorbalance.h \
colorbalancechannel.h
+built_headers = \
+ colorbalancemarshal.h
+ colorbalanceenumtypes.h
+
+libgstcolorbalanceinclude_HEADERS = $(colorbalance_headers) $(built_headers)
+
noinst_LTLIBRARIES = libgstcolorbalance.la
libgstcolorbalance_la_SOURCES = \
colorbalance.c \
colorbalancechannel.c \
- colorbalancemarshal.c
+ colorbalancemarshal.c \
+ colorbalanceenumtypes.c
libgstcolorbalance_la_CFLAGS = $(GST_CFLAGS) $(GST_OPT_CFLAGS)
BUILT_SOURCES = \
colorbalancemarshal.c \
- colorbalancemarshal.h
-built_headers = \
- colorbalancemarshal.h
+ colorbalancemarshal.h \
+ colorbalanceenumtypes.c \
+ colorbalanceenumtypes.h
EXTRA_DIST = colorbalancemarshal.list
@@ -31,3 +38,20 @@ colorbalancemarshal.c: colorbalancemarshal.list
echo "#include \"colorbalancemarshal.h\"" >> colorbalancemarshal.c.tmp
glib-genmarshal --body --prefix=gst_color_balance_marshal $^ >> colorbalancemarshal.c.tmp
mv colorbalancemarshal.c.tmp colorbalancemarshal.c
+
+colorbalanceenumtypes.h: $(colorbalance_headers)
+ glib-mkenums \
+ --fhead "#ifndef __GST_COLOR_BALANCE_ENUM_TYPES_H__\n#define __GST_COLOR_BALANCE_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
+ --fprod "/* enumerations from \"@filename@\" */\n" \
+ --vhead "GType @enum_name@_get_type (void);\n#define GST_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \
+ --ftail "G_END_DECLS\n\n#endif /* __GST_COLOR_BALANCE_ENUM_TYPES_H__ */" \
+ $^ > $@
+
+colorbalanceenumtypes.c: $(colorbalance_headers)
+ glib-mkenums \
+ --fhead "#include <colorbalance.h>" \
+ --fprod "\n/* enumerations from \"@filename@\" */" \
+ --vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \
+ --vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \
+ --vtail " { 0, NULL, NULL }\n };\n etype = g_@type@_register_static (\"@EnumName@\", values);\n }\n return etype;\n}\n" \
+ $^ > $@