summaryrefslogtreecommitdiffstats
path: root/ext/arts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/arts/Makefile.am')
-rw-r--r--ext/arts/Makefile.am17
1 files changed, 1 insertions, 16 deletions
diff --git a/ext/arts/Makefile.am b/ext/arts/Makefile.am
index 6f281da6..48af875c 100644
--- a/ext/arts/Makefile.am
+++ b/ext/arts/Makefile.am
@@ -2,11 +2,6 @@ plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
plugin_LTLIBRARIES = libgstarts.la
-
-## we wrap parts of this Makefile.am in a USE_ so that we won't run
-## mcopidl during make distcheck when it isn't on the system
-
-if USE_ARTS
SUFFIXES = .idl
.idl.cc:
mcopidl -t $< $(ARTS_CXXFLAGS)
@@ -14,12 +9,7 @@ SUFFIXES = .idl
# mcopidl Extension Expansion Technology clean up
CLEANFILES = gst_artsio.h gst_artsio.cc gst_artsio.mcopclass gst_artsio.mcoptype
-# FIXME automake 1.4 hack, 1.5 should let us put the .idl in
-# _SOURCES at which point the follow can be removed
-
-gst_artsio_impl.lo: gst_artsio.cc
-
-libgstarts_la_SOURCES = gst_arts.c gst_artsio.cc gst_artsio_impl.cc
+libgstarts_la_SOURCES = gst_arts.c gst_artsio.idl gst_artsio_impl.cc
libgstarts_la_CFLAGS = $(GST_CFLAGS)
libgstarts_la_CXXFLAGS = $(ARTS_CXXFLAGS) $(GST_CFLAGS)
libgstarts_la_LIBADD = $(ARTS_LIBS) -lartsflow -lartsflow_idl
@@ -28,9 +18,4 @@ libgstarts_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
dist-hook:
rm -f $(distdir)/gst_artsio.cc
-EXTRA_DIST = gst_artsio.idl
-else
-EXTRA_DIST = gst_arts.c gst_artsio.idl gst_artsio_impl.cc
-endif
-
noinst_HEADERS = gst_arts.h gst_artsio_impl.h