summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-06-10 04:01:53 +0000
committerDavid Robillard <d@drobilla.net>2006-06-10 04:01:53 +0000
commit9a3d8d0604a2f81e3514e8a1a30aaf41aadf73a2 (patch)
tree87747e973904777ab553bb456d354f487a943f15 /configure.ac
parenta8014efbed9eae51ebb78433f7173c8fdbef70eb (diff)
downloadingen-9a3d8d0604a2f81e3514e8a1a30aaf41aadf73a2.tar.gz
ingen-9a3d8d0604a2f81e3514e8a1a30aaf41aadf73a2.tar.bz2
ingen-9a3d8d0604a2f81e3514e8a1a30aaf41aadf73a2.zip
Actually got all this stuff building again
git-svn-id: http://svn.drobilla.net/lad/grauph@21 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 25 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index bcd431f5..e6e2aeba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,14 @@
AC_PREREQ(2.59)
AC_INIT([om],[0.3.0pre],[drobilla@connect.carleton.ca])
-AC_CONFIG_SRCDIR([src/engine/main.cpp])
-AC_CONFIG_SRCDIR([src/engine/tests/node_tree_test.cpp])
-AC_CONFIG_SRCDIR([src/clients/OSCController.cpp])
-AC_CONFIG_SRCDIR([src/clients/patch_loader/patch_loader.cpp])
-AC_CONFIG_SRCDIR([src/clients/demolition/demolition.cpp])
-AC_CONFIG_SRCDIR([src/clients/gtk/main.cpp])
+AC_CONFIG_SRCDIR([src/common/util/CountedPtr.h])
+AC_CONFIG_SRCDIR([src/common/interface/EngineInterface.h])
+AC_CONFIG_SRCDIR([src/libs/engine/JackAudioDriver.cpp])
+AC_CONFIG_SRCDIR([src/libs/engine/tests/node_tree_test.cpp])
+AC_CONFIG_SRCDIR([src/libs/client/OSCController.cpp])
+AC_CONFIG_SRCDIR([src/progs/engine/main.cpp])
+AC_CONFIG_SRCDIR([src/progs/patch_loader/patch_loader.cpp])
+AC_CONFIG_SRCDIR([src/progs/demolition/demolition.cpp])
+AC_CONFIG_SRCDIR([src/progs/gtk/main.cpp])
AC_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE
@@ -317,23 +320,29 @@ else
fi
AM_CONDITIONAL(BUILD_GTK_CLIENT, [test "$build_gtk_client" = "yes"])
+# Build client lib if anything above that depends on it is to be built
+AM_CONDITIONAL(BUILD_CLIENT_LIB, [test "$build_console_clients" = "yes" -o "$build_gtk_client" = "yes"])
+
# Write Makefiles
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([src/Makefile])
-AC_CONFIG_FILES([src/engine/Makefile])
-AC_CONFIG_FILES([src/engine/tests/Makefile])
AC_CONFIG_FILES([src/common/Makefile])
AC_CONFIG_FILES([src/common/util/Makefile])
AC_CONFIG_FILES([src/common/interface/Makefile])
-AC_CONFIG_FILES([src/clients/Makefile])
-AC_CONFIG_FILES([src/clients/supercollider/Makefile])
-AC_CONFIG_FILES([src/clients/python/Makefile])
-AC_CONFIG_FILES([src/clients/python/scripts/Makefile])
-AC_CONFIG_FILES([src/clients/demolition/Makefile])
-AC_CONFIG_FILES([src/clients/patch_loader/Makefile])
-AC_CONFIG_FILES([src/clients/patches/Makefile])
-AC_CONFIG_FILES([src/clients/gtk/Makefile])
+AC_CONFIG_FILES([src/libs/Makefile])
+AC_CONFIG_FILES([src/libs/engine/Makefile])
+AC_CONFIG_FILES([src/libs/engine/tests/Makefile])
+AC_CONFIG_FILES([src/libs/client/Makefile])
+AC_CONFIG_FILES([src/progs/Makefile])
+AC_CONFIG_FILES([src/progs/om/Makefile])
+AC_CONFIG_FILES([src/progs/supercollider/Makefile])
+AC_CONFIG_FILES([src/progs/python/Makefile])
+AC_CONFIG_FILES([src/progs/python/scripts/Makefile])
+AC_CONFIG_FILES([src/progs/demolition/Makefile])
+AC_CONFIG_FILES([src/progs/patch_loader/Makefile])
+AC_CONFIG_FILES([src/progs/gtk/Makefile])
+AC_CONFIG_FILES([patches/Makefile])
AC_OUTPUT
# Display summary