summaryrefslogtreecommitdiffstats
path: root/src/libs/client/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-07-24 06:48:02 +0000
committerDavid Robillard <d@drobilla.net>2007-07-24 06:48:02 +0000
commitcf1c161a0209cdce869a3e8c3b48b1d53c1bab00 (patch)
treef56c68b22bb013127ed5bc02501ee124ae46d873 /src/libs/client/Makefile.am
parentdb1861e76aa1a42789c78f37f110cc81c0339a2d (diff)
downloadingen-cf1c161a0209cdce869a3e8c3b48b1d53c1bab00.tar.gz
ingen-cf1c161a0209cdce869a3e8c3b48b1d53c1bab00.tar.bz2
ingen-cf1c161a0209cdce869a3e8c3b48b1d53c1bab00.zip
Removed recursive autohell, except for SLv2.
Always build against local copies, hopefully fixing broken compilation against outdated system versions. git-svn-id: http://svn.drobilla.net/lad/ingen@610 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/libs/client/Makefile.am')
-rw-r--r--src/libs/client/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/libs/client/Makefile.am b/src/libs/client/Makefile.am
index 7250de36..1c009868 100644
--- a/src/libs/client/Makefile.am
+++ b/src/libs/client/Makefile.am
@@ -6,14 +6,16 @@ moduledir = $(libdir)/ingen
module_LTLIBRARIES = libingen_client.la
libingen_client_la_CXXFLAGS = \
- @RAUL_CFLAGS@ @SLV2_CFLAGS@ @LOSC_CFLAGS@ \
+ -I$(top_srcdir)/slv2 \
+ -I$(top_srcdir)/raul \
+ -I$(top_srcdir)/ingen/src/common \
+ -DPKGDATADIR=\"$(pkgdatadir)\" \
+ @LIBLO_CFLAGS@ \
@LXML2_CFLAGS@ @RASQAL_CFLAGS@ @RAPTOR_CFLAGS@ \
- @LSIGCPP_CFLAGS@ @GLIBMM_CFLAGS@ \
- -I$(top_srcdir)/src/common \
- -DPKGDATADIR=\"$(pkgdatadir)\"
+ @LSIGCPP_CFLAGS@ @GLIBMM_CFLAGS@
libingen_client_la_LIBADD = \
- @RAUL_LIBS@ @SLV2_LIBS@ @LOSC_LIBS@ \
+ @RAUL_LIBS@ @SLV2_LIBS@ @LIBLO_LIBS@ \
@LXML2_LIBS@ @RASQAL_LIBS@ @RAPTOR_LIBS@ \
@LSIGCPP_LIBS@ @GLIBMM_LIBS@
@@ -48,8 +50,8 @@ libingen_client_la_SOURCES = \
ConnectionModel.cpp \
Store.h \
Store.cpp \
- $(top_srcdir)/src/common/interface/ClientInterface.h \
- $(top_srcdir)/src/common/interface/EngineInterface.h
+ $(top_srcdir)/ingen/src/common/interface/ClientInterface.h \
+ $(top_srcdir)/ingen/src/common/interface/EngineInterface.h
endif # BUILD_CLIENT_LIB