summaryrefslogtreecommitdiffstats
path: root/src/libs/engine/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-10-04 07:11:09 +0000
committerDavid Robillard <d@drobilla.net>2006-10-04 07:11:09 +0000
commit32261ba465be203f973a0e126672b8d7188ba327 (patch)
treefcab8b01ffeb2c1955b8f712c5f3eef6e1f13f2b /src/libs/engine/Makefile.am
parent1e01da451b279943ed51999ee06d64aba7c8faa2 (diff)
downloadingen-32261ba465be203f973a0e126672b8d7188ba327.tar.gz
ingen-32261ba465be203f973a0e126672b8d7188ba327.tar.bz2
ingen-32261ba465be203f973a0e126672b8d7188ba327.zip
Global build system, build system bugfixes.
git-svn-id: http://svn.drobilla.net/lad/ingen@154 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/libs/engine/Makefile.am')
-rw-r--r--src/libs/engine/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/src/libs/engine/Makefile.am b/src/libs/engine/Makefile.am
index 95b684d5..ac58885f 100644
--- a/src/libs/engine/Makefile.am
+++ b/src/libs/engine/Makefile.am
@@ -1,5 +1,4 @@
-SUBDIRS = tests
-DIST_SUBDIRS = events
+SUBDIRS = tests events
AM_CXXFLAGS = @JACK_CFLAGS@ @LOSC_CFLAGS@ @ALSA_CFLAGS@ @LASH_CFLAGS@ @SLV2_CFLAGS@ -I$(top_srcdir)/src/common -I$(top_srcdir)/src/libs/engine/events
@@ -12,6 +11,7 @@ noinst_LTLIBRARIES = libingen.la
libingen_la_SOURCES = \
util.h \
tuning.h \
+ events.h \
DataType.h \
Node.h \
NodeBase.h \
@@ -31,7 +31,6 @@ libingen_la_SOURCES = \
DirectResponder.h \
OSCResponder.h \
OSCResponder.cpp \
- ClientKey.h \
ClientBroadcaster.h \
ClientBroadcaster.cpp \
ObjectSender.h \
@@ -68,7 +67,7 @@ libingen_la_SOURCES = \
Maid.cpp \
MaidObject.h \
Tree.h \
- ClientRecord.h \
+ TreeImplementation.h \
PluginLibrary.h \
Plugin.h \
Plugin.cpp \
@@ -88,12 +87,6 @@ libingen_la_SOURCES = \
AudioDriver.h \
MidiDriver.h \
midi.h \
- ../libingen_la/util/Semaphore.h \
- ../libingen_la/util/types.h \
- ../libingen_la/util/Path.h \
- ../libingen_la/util/Queue.h \
- ../libingen_la/interface/ClientInterface.h \
- ../libingen_la/interface/EngineInterface.h \
instantiations.cpp \
events/RegisterClientEvent.h \
events/RegisterClientEvent.cpp \
@@ -213,7 +206,6 @@ endif
if WITH_LASH
libingen_la_SOURCES += \
LashDriver.h \
- LashDriver.cpp \
- LashRestoreDoneEvent.h
+ LashDriver.cpp
endif