summaryrefslogtreecommitdiffstats
path: root/src/progs/ingenuity/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-05-04 03:59:38 +0000
committerDavid Robillard <d@drobilla.net>2007-05-04 03:59:38 +0000
commita96166710faf2447ed10194d1829db5564b0dff9 (patch)
tree4eb792fcceee17f188566fc6e6bee11e5a8c4336 /src/progs/ingenuity/Makefile.am
parentcf14d321e8f084f742b03e09c086d5ef30297492 (diff)
downloadingen-a96166710faf2447ed10194d1829db5564b0dff9.tar.gz
ingen-a96166710faf2447ed10194d1829db5564b0dff9.tar.bz2
ingen-a96166710faf2447ed10194d1829db5564b0dff9.zip
Made engine, serialisation, client library, and GUI all dynamically loaded modules.
Combined all executables into a single "ingen" program which can do everything. git-svn-id: http://svn.drobilla.net/lad/ingen@493 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/progs/ingenuity/Makefile.am')
-rw-r--r--src/progs/ingenuity/Makefile.am98
1 files changed, 0 insertions, 98 deletions
diff --git a/src/progs/ingenuity/Makefile.am b/src/progs/ingenuity/Makefile.am
deleted file mode 100644
index 82d96b15..00000000
--- a/src/progs/ingenuity/Makefile.am
+++ /dev/null
@@ -1,98 +0,0 @@
-if BUILD_GTK_CLIENT
-
-EXTRA_DIST = ingenuity.gladep ingenuity_dev
-MAINTAINERCLEANFILES = Makefile.in
-
-sharefilesdir = $(pkgdatadir)
-dist_sharefiles_DATA = ingenuity.glade ingen.svg
-
-desktopfilesdir = $(datadir)/applications
-dist_desktopfiles_DATA = ingenuity.desktop
-
-globalpixmapsdir = $(datadir)/pixmaps
-dist_globalpixmaps_DATA = ingen.svg
-
-ingenuity_CXXFLAGS = -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -I$(top_srcdir)/src/common -I$(top_srcdir)/src/libs -DPKGDATADIR=\"$(pkgdatadir)\" @RAUL_CFLAGS@ @GTKMM_CFLAGS@ @LIBGLADEMM_CFLAGS@ @GNOMECANVASMM_CFLAGS@ @LOSC_CFLAGS@ @LASH_CFLAGS@ @FLOWCANVAS_CFLAGS@ @SLV2_CFLAGS@ @CURL_CFLAGS@ -DINGEN_MODULE_DIR=\"$(libdir)/ingen\"
-ingenuity_LDADD = @RAUL_LIBS@ @GTKMM_LIBS@ @LIBGLADEMM_LIBS@ @GNOMECANVASMM_LIBS@ @LOSC_LIBS@ @LASH_LIBS@ @FLOWCANVAS_LIBS@ @SLV2_LIBS@ @CURL_LIBS@ ../../libs/client/libingen_client.la ../../libs/module/libingen_module.la
-ingenuity_DEPENDENCIES = ../../libs/client/libingen_client.la ../../libs/module/libingen_module.la
-
-bin_PROGRAMS = ingenuity
-ingenuity_SOURCES = \
- cmdline.h \
- cmdline.c \
- main.cpp \
- NodeMenu.h \
- NodeMenu.cpp \
- PatchCanvas.h \
- PatchCanvas.cpp \
- BreadCrumb.h \
- BreadCrumbBox.h \
- BreadCrumbBox.cpp \
- ConnectWindow.h \
- ConnectWindow.cpp \
- App.h \
- App.cpp \
- Configuration.h \
- Configuration.cpp \
- GladeFactory.h \
- GladeFactory.cpp \
- LoadPluginWindow.h \
- LoadPluginWindow.cpp \
- LoadPatchWindow.h \
- LoadPatchWindow.cpp \
- LoadRemotePatchWindow.h \
- LoadRemotePatchWindow.cpp \
- UploadPatchWindow.h \
- UploadPatchWindow.cpp \
- MessagesWindow.h \
- MessagesWindow.cpp \
- LoadSubpatchWindow.h \
- LoadSubpatchWindow.cpp \
- NodeControlWindow.h \
- NodeControlWindow.cpp \
- ControlPanel.h \
- ControlPanel.cpp \
- ControlGroups.h \
- ControlGroups.cpp \
- PatchView.h \
- PatchView.cpp \
- PatchWindow.h \
- PatchWindow.cpp \
- WindowFactory.h \
- WindowFactory.cpp \
- NodeModule.h \
- NodeModule.cpp \
- PatchPortModule.h \
- PatchPortModule.cpp \
- DSSIModule.h \
- DSSIModule.cpp \
- DSSIController.h \
- DSSIController.cpp \
- SubpatchModule.h \
- SubpatchModule.cpp \
- Port.h \
- Port.cpp \
- Connection.h \
- NewSubpatchWindow.h \
- NewSubpatchWindow.cpp \
- ConfigWindow.h \
- ConfigWindow.cpp \
- PatchPropertiesWindow.h \
- PatchPropertiesWindow.cpp \
- ThreadedLoader.h \
- ThreadedLoader.cpp \
- RenameWindow.h \
- RenameWindow.cpp \
- NodePropertiesWindow.h \
- NodePropertiesWindow.cpp \
- PortPropertiesWindow.h \
- PortPropertiesWindow.cpp \
- PatchTreeWindow.h \
- PatchTreeWindow.cpp
-
-if WITH_LASH
-ingenuity_SOURCES += LashController.h LashController.cpp
-endif
-
-
-endif # WITH_GTK_CLIENT