summaryrefslogtreecommitdiffstats
path: root/src/progs/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/progs/server/Makefile.am')
-rw-r--r--src/progs/server/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/progs/server/Makefile.am b/src/progs/server/Makefile.am
new file mode 100644
index 00000000..9ba20719
--- /dev/null
+++ b/src/progs/server/Makefile.am
@@ -0,0 +1,43 @@
+AM_CXXFLAGS = @JACK_CFLAGS@ @LOSC_CFLAGS@ @ALSA_CFLAGS@ @LASH_CFLAGS@ @SLV2_CFLAGS@ -I$(top_srcdir)/src/common -I$(top_srcdir)/src/libs/engine -I$(top_srcdir)/src/libs/engine/events -fno-exceptions -fno-rtti
+
+MAINTAINERCLEANFILES = Makefile.in
+
+#
+# Stand-alone engine
+#
+if BUILD_ENGINE
+
+bin_PROGRAMS = ingen
+om_DEPENDENCIES = ../../libs/engine/libingen.la
+om_LDADD = @JACK_LIBS@ @LOSC_LIBS@ @ALSA_LIBS@ @LASH_LIBS@ @SLV2_LIBS@ -lrt ../../libs/engine/libingen.la
+
+om_SOURCES = \
+ main.cpp \
+ cmdline.h \
+ cmdline.c
+
+endif # BUILD_ENGINE
+
+
+##
+## Jack internal client
+##
+#if BUILD_IN_PROCESS_ENGINE
+#
+#
+## FIXME: broken
+#
+#
+## FIXME: Figure out how to get this properly
+#omdir = $(prefix)/lib/jack
+#
+#om_la_CFLAGS = -fPIC
+#om_LTLIBRARIES = om.la
+#om_la_LDFLAGS = -module -avoid-version @JACK_LIBS@ @LOSC_LIBS@ @ALSA_LIBS@ @LASH_LIBS@ @SLV2_LIBS@
+#om_la_SOURCES = OmInProcess.cpp
+#
+#endif # BUILD_IN_PROCESS_ENGINE
+
+
+
+