summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build22
1 files changed, 1 insertions, 21 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 39395bae..1637230b 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -96,25 +96,5 @@ endforeach
########
if get_option('lint')
- if not meson.is_subproject()
- # Check code with cppcheck
- cppcheck = find_program('cppcheck', required: false)
- if cppcheck.found()
- compdb_path = join_paths(ingen_build_root, 'compile_commands.json')
- suppress_path = join_paths(ingen_src_root, '.suppress.cppcheck')
- test(
- 'cppcheck',
- cppcheck,
- args: [
- '--enable=warning,style,performance,portability',
- '--error-exitcode=1',
- '--project=' + compdb_path,
- '--suppressions-list=' + suppress_path,
- '-q',
- ],
- suite: 'code',
- timeout: 60,
- )
- endif
- endif
+ subdir('lint')
endif