summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-01-10 04:13:33 +0000
committerDavid Robillard <d@drobilla.net>2007-01-10 04:13:33 +0000
commit3a6b07eca33cb6ae586c80141315958d1e348f38 (patch)
treeb8582c2ded94f75c247fefc1500e68dcb8c4778f /configure.ac
parent2fcb9c82c015524f7282b77ecd91d9e1f8db76e9 (diff)
downloadlilv-3a6b07eca33cb6ae586c80141315958d1e348f38.tar.gz
lilv-3a6b07eca33cb6ae586c80141315958d1e348f38.tar.bz2
lilv-3a6b07eca33cb6ae586c80141315958d1e348f38.zip
Skeleton LADSPA->LV2 conversion utility.
git-svn-id: http://svn.drobilla.net/lad/slv2@245 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f26f338..9dfe443 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,6 +2,7 @@ AC_PREREQ(2.59)
AC_INIT([libslv2],[0.0.1],[drobilla@connect.carleton.ca])
AC_CONFIG_SRCDIR([src/plugin.c])
AC_CONFIG_SRCDIR([slv2/plugin.h])
+AC_CONFIG_SRCDIR([utils/ladspa2lv2.c])
AC_CONFIG_SRCDIR([examples/plugins/Amp-swh.lv2/amp.c])
AC_CONFIG_SRCDIR([examples/hosts/test_host.c])
AC_CONFIG_HEADER([config.h])
@@ -39,6 +40,13 @@ if test "$strict" = "yes"; then
CFLAGS="$CFLAGS -std=c99 -pedantic -Wall -Wextra -Wconversion -Winit-self"
fi
+# Build utilities?
+build_utilities="no"
+AC_ARG_ENABLE(utilities,
+ [AS_HELP_STRING(--enable-utilities, [Build utilities (no) - EXPERIMENTAL])],
+ [build_utilities="$enableval"])
+AM_CONDITIONAL(BUILD_UTILITIES, [test "$build_utilities" = "yes"])
+
# Bolt on a few specific flags to CXXFLAGS that should always be used
#CFLAGS="$CFLAGS -pipe -Wall -fmessage-length=139 -fdiagnostics-show-location=every-line"
@@ -51,6 +59,9 @@ AC_ARG_WITH(lv2-dir,
AC_MSG_RESULT($lv2dir)
AC_SUBST(lv2dir)
+# Check for RAPTOR
+PKG_CHECK_MODULES(RAPTOR, raptor >= 0.21, build_raptor="yes", build_raptor="no")
+
# Check for RASQAL
PKG_CHECK_MODULES(RASQAL, rasqal >= 0.9.11, build_rasqal="yes", build_rasqal="no")
@@ -74,6 +85,7 @@ AM_CONDITIONAL(WITH_JACK, [test "$build_jack" = "yes"])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([src/Makefile])
AC_CONFIG_FILES([slv2/Makefile])
+AC_CONFIG_FILES([utils/Makefile])
AC_CONFIG_FILES([examples/Makefile])
AC_CONFIG_FILES([examples/plugins/Makefile])
AC_CONFIG_FILES([examples/hosts/Makefile])