summaryrefslogtreecommitdiffstats
path: root/doc/c/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-14 11:50:43 -0400
committerDavid Robillard <d@drobilla.net>2022-07-18 20:18:28 -0400
commit55dc97a32eeeb42012ce1e7d28ed99ea537f4d2f (patch)
treec0fc78d78609c1bd3e880499bd0e80a4498b0be3 /doc/c/meson.build
parent891f4044c92117517041c9e7ee4099b75bd493da (diff)
downloadlilv-55dc97a32eeeb42012ce1e7d28ed99ea537f4d2f.tar.gz
lilv-55dc97a32eeeb42012ce1e7d28ed99ea537f4d2f.tar.bz2
lilv-55dc97a32eeeb42012ce1e7d28ed99ea537f4d2f.zip
Switch to meson build system
Diffstat (limited to 'doc/c/meson.build')
-rw-r--r--doc/c/meson.build47
1 files changed, 47 insertions, 0 deletions
diff --git a/doc/c/meson.build b/doc/c/meson.build
new file mode 100644
index 0000000..f75dc74
--- /dev/null
+++ b/doc/c/meson.build
@@ -0,0 +1,47 @@
+config = configuration_data()
+config.set('LILV_VERSION', meson.project_version())
+
+conf_py = configure_file(configuration: config,
+ input: files('../conf.py.in'),
+ output: 'conf.py')
+
+configure_file(copy: true,
+ input: files('../summary.rst'),
+ output: 'summary.rst')
+
+c_rst_files = files(
+ 'index.rst',
+ 'overview.rst',
+ 'plugins.rst',
+ 'uis.rst',
+ 'world.rst',
+)
+
+foreach f : c_rst_files
+ configure_file(copy: true, input: f, output: '@PLAINNAME@')
+endforeach
+
+subdir('xml')
+subdir('api')
+
+docs = custom_target(
+ 'singlehtml',
+ build_by_default: true,
+ command: [sphinx_build, '-M', 'singlehtml', '@OUTDIR@', '@OUTDIR@',
+ '-E', '-q', '-t', 'singlehtml'],
+ input: [c_rst_files, c_lilv_rst, c_index_xml],
+ install: true,
+ install_dir: docdir / 'lilv-0',
+ output: 'singlehtml',
+)
+
+docs = custom_target(
+ 'html',
+ build_by_default: true,
+ command: [sphinx_build, '-M', 'html', '@OUTDIR@', '@OUTDIR@',
+ '-E', '-q', '-t', 'html'],
+ input: [c_rst_files, c_lilv_rst, c_index_xml],
+ install: true,
+ install_dir: docdir / 'lilv-0',
+ output: 'html',
+)