summaryrefslogtreecommitdiffstats
path: root/doc/html/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-09-23 17:01:42 -0400
committerDavid Robillard <d@drobilla.net>2023-09-23 17:01:42 -0400
commitc57b77099bd2cdc4fd8072f4cb314caecd6753ec (patch)
treedd1cb6c70d443ad47614a7e4c23f38db21d701a3 /doc/html/meson.build
parent152cff7f33d10c9f02ca0993deb078b4ef672631 (diff)
downloadlilv-c57b77099bd2cdc4fd8072f4cb314caecd6753ec.tar.gz
lilv-c57b77099bd2cdc4fd8072f4cb314caecd6753ec.tar.bz2
lilv-c57b77099bd2cdc4fd8072f4cb314caecd6753ec.zip
Clean up sphinx build commands
Diffstat (limited to 'doc/html/meson.build')
-rw-r--r--doc/html/meson.build13
1 files changed, 6 insertions, 7 deletions
diff --git a/doc/html/meson.build b/doc/html/meson.build
index df7cb72..59da474 100644
--- a/doc/html/meson.build
+++ b/doc/html/meson.build
@@ -8,13 +8,12 @@ html_dir = docdir / versioned_name / 'html'
custom_target(
'html',
build_by_default: true,
- command: [
- sphinx_build,
- '-M', 'html',
- '@OUTDIR@' / '..',
- '@OUTDIR@' / '..',
+ command: sphinx_build_command + [
+ '-b', 'html',
'-t', 'html',
- ] + sphinx_flags,
+ sphinx_in_dir,
+ '@OUTDIR@',
+ ],
input: [api_lilv_rst, conf_py, sphinx_input],
install: true,
install_dir: html_dir,
@@ -33,7 +32,7 @@ custom_target(
if not meson.is_subproject()
summary(
- 'Paginated HTML',
+ 'HTML',
get_option('prefix') / html_dir,
section: 'Directories',
)