summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-09-23 17:01:42 -0400
committerDavid Robillard <d@drobilla.net>2023-09-23 17:01:42 -0400
commitc57b77099bd2cdc4fd8072f4cb314caecd6753ec (patch)
treedd1cb6c70d443ad47614a7e4c23f38db21d701a3 /doc/meson.build
parent152cff7f33d10c9f02ca0993deb078b4ef672631 (diff)
downloadlilv-c57b77099bd2cdc4fd8072f4cb314caecd6753ec.tar.gz
lilv-c57b77099bd2cdc4fd8072f4cb314caecd6753ec.tar.bz2
lilv-c57b77099bd2cdc4fd8072f4cb314caecd6753ec.zip
Clean up sphinx build commands
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
index ffdefdd..32a885b 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -51,12 +51,14 @@ if build_docs
subdir('api')
# Build strict Sphinx flags, with termination on warnings if werror=true
+ sphinx_in_dir = meson.current_build_dir()
sphinx_flags = ['-E', '-a', '-q']
if get_option('werror')
sphinx_flags += ['-W']
endif
# Run Sphinx to generate final documentation for each format
+ sphinx_build_command = [sphinx_build] + sphinx_flags
foreach format : ['html', 'singlehtml']
if not get_option(format).disabled()
subdir(format)