summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-08 19:07:17 -0500
committerDavid Robillard <d@drobilla.net>2022-12-08 19:07:59 -0500
commite47ee08c5d497fe921cc264c2573bfc21f492cf6 (patch)
tree3c40e00c218228cfabcc5d8b9320809da0c30246 /doc/meson.build
parent06b58d64bdf3bdea0d95da1b700e66937756e77d (diff)
downloadlilv-e47ee08c5d497fe921cc264c2573bfc21f492cf6.tar.gz
lilv-e47ee08c5d497fe921cc264c2573bfc21f492cf6.tar.bz2
lilv-e47ee08c5d497fe921cc264c2573bfc21f492cf6.zip
Replace duplicated dox_to_sphinx script with sphinxygen dependency
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/doc/meson.build b/doc/meson.build
index db68e86..7c633a0 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -4,10 +4,15 @@
docdir = get_option('datadir') / 'doc'
doxygen = find_program('doxygen', required: get_option('docs'))
-dox_to_sphinx = files('../scripts/dox_to_sphinx.py')
+sphinxygen = find_program('sphinxygen', required: false)
sphinx_build = find_program('sphinx-build', required: get_option('docs'))
-build_docs = doxygen.found() and sphinx_build.found()
+if not sphinxygen.found()
+ subproject('sphinxygen')
+ sphinxygen = find_program('sphinxygen', required: get_option('docs'))
+endif
+
+build_docs = doxygen.found() and sphinxygen.found() and sphinx_build.found()
if build_docs
subdir('c')