summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-11 08:53:26 -0500
committerDavid Robillard <d@drobilla.net>2022-12-11 08:53:26 -0500
commit09eb752cf245c33326bc98f8292ec04d477ab121 (patch)
tree2ed7e39e52c5284974010903a696dfee6a528025 /meson.build
parent02446e898d8991fab606aa8d3d964af19d2e4b4f (diff)
downloadlilv-09eb752cf245c33326bc98f8292ec04d477ab121.tar.gz
lilv-09eb752cf245c33326bc98f8292ec04d477ab121.tar.bz2
lilv-09eb752cf245c33326bc98f8292ec04d477ab121.zip
Remove unused platform feature checks
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 4920b23..d382ff4 100644
--- a/meson.build
+++ b/meson.build
@@ -42,13 +42,8 @@ subdir('meson/suppressions')
##########################
platform_defines = ['-DLILV_VERSION="@0@"'.format(meson.project_version())]
-if host_machine.system() == 'darwin'
+if host_machine.system() in ['gnu', 'linux']
platform_defines += [
- '-D_DARWIN_C_SOURCE',
- ]
-elif host_machine.system() in ['gnu', 'linux']
- platform_defines += [
- '-D_DEFAULT_SOURCE',
'-D_POSIX_C_SOURCE=200809L',
]
endif