summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-12-10 15:53:56 -0500
committerDavid Robillard <d@drobilla.net>2022-12-10 19:04:45 -0500
commitd4dff3e6e9ea3c96d77c9b8f532dec070bdab850 (patch)
tree0e17dece1bb28597874624fe6fbf733da747f223 /meson.build
parent66ad3770c761ab03ca1f67b15b32bebb6a4f2cac (diff)
downloadlilv-d4dff3e6e9ea3c96d77c9b8f532dec070bdab850.tar.gz
lilv-d4dff3e6e9ea3c96d77c9b8f532dec070bdab850.tar.bz2
lilv-d4dff3e6e9ea3c96d77c9b8f532dec070bdab850.zip
Resurrect C++ bindings test
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index aeb79bf..4920b23 100644
--- a/meson.build
+++ b/meson.build
@@ -20,10 +20,17 @@ versioned_name = 'lilv' + version_suffix
# Compilers and Flags #
#######################
-# Load build tools
+# Required tools
pkg = import('pkgconfig')
cc = meson.get_compiler('c')
+# Enable C++ support if bindings aren't disabled
+if not get_option('bindings_cpp').disabled()
+ if add_languages(['cpp'], native: false, required: false)
+ cpp = meson.get_compiler('cpp')
+ endif
+endif
+
# Set global warning flags
if get_option('strict') and not meson.is_subproject()
subdir('meson/warnings')