summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-14 20:03:30 -0400
committerDavid Robillard <d@drobilla.net>2023-05-14 20:03:30 -0400
commitd564baafed0863813a87d872f8663134e74228c8 (patch)
tree69c80abc4ed6d011beac6a2904938830024dc220 /meson.build
parent99540a8f30408d15339ececc4c28f27e2e2f06ab (diff)
downloadlilv-d564baafed0863813a87d872f8663134e74228c8.tar.gz
lilv-d564baafed0863813a87d872f8663134e74228c8.tar.bz2
lilv-d564baafed0863813a87d872f8663134e74228c8.zip
Clean up documentation and remove junk files from install
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build41
1 files changed, 25 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index 115994e..5864f2e 100644
--- a/meson.build
+++ b/meson.build
@@ -184,6 +184,31 @@ meson.override_dependency(versioned_name, lilv_dep)
install_headers(c_headers, subdir: versioned_name / 'lilv')
install_headers(cpp_headers, subdir: versioned_name / 'lilv')
+# Display top-level summary (before subdirectories to appear first)
+if not meson.is_subproject()
+ summary(
+ {
+ 'Tests': not get_option('tests').disabled(),
+ 'Tools': not get_option('tools').disabled(),
+ },
+ bool_yn: true,
+ section: 'Components',
+ )
+
+ summary('Default LV2_PATH', default_lv2_path, section: 'Configuration')
+
+ summary(
+ {
+ 'Install prefix': get_option('prefix'),
+ 'Headers': get_option('prefix') / get_option('includedir'),
+ 'Libraries': get_option('prefix') / get_option('libdir'),
+ 'Executables': get_option('prefix') / get_option('bindir'),
+ 'Man pages': get_option('prefix') / get_option('mandir'),
+ },
+ section: 'Directories',
+ )
+endif
+
#########
# Tools #
#########
@@ -234,19 +259,3 @@ if not get_option('tests').disabled()
# Build and run tests against static library
subdir('test')
endif
-
-if not meson.is_subproject()
- summary('Tests', not get_option('tests').disabled(), bool_yn: true)
- summary('Tools', not get_option('tools').disabled(), bool_yn: true)
-
- summary('Install prefix', get_option('prefix'))
- summary('Default LV2_PATH', default_lv2_path)
-
- summary('Headers', get_option('prefix') / get_option('includedir'))
- summary('Libraries', get_option('prefix') / get_option('libdir'))
-
- if not get_option('tools').disabled()
- summary('Executables', get_option('prefix') / get_option('bindir'))
- summary('Man pages', get_option('prefix') / get_option('mandir'))
- endif
-endif