summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-07-29 17:20:23 +0000
committerDavid Robillard <d@drobilla.net>2007-07-29 17:20:23 +0000
commitadd7dd9f6b1bc17519d7c64282a7f2295735951c (patch)
tree8d11bb0aa787fa563ca18471c795ca90d8429a1d /src/Makefile.am
parentbd6f6beb3137bb637aced8b68873513b4c7dc769 (diff)
downloadlilv-add7dd9f6b1bc17519d7c64282a7f2295735951c.tar.gz
lilv-add7dd9f6b1bc17519d7c64282a7f2295735951c.tar.bz2
lilv-add7dd9f6b1bc17519d7c64282a7f2295735951c.zip
Build system fixes, building from top level doesn't recursively configure slv2, but slv2 is still independently packageable/buildable.
Think I've finally figured out how to do recursive autohell without resorting to suicide... git-svn-id: http://svn.drobilla.net/lad/slv2@650 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 43543b5..a85a1af 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,4 @@
-AM_CFLAGS = -std=c99 -I$(top_srcdir)/include -I$(top_srcdir) @REDLAND_CFLAGS@ -DLIBSLV2_SOURCE
-AM_LDFLAGS = `pkg-config --libs rasqal`
+AM_CFLAGS = -std=c99 @SLV2_CFLAGS@ @REDLAND_CFLAGS@ -DLIBSLV2_SOURCE
lib_LTLIBRARIES = libslv2.la
libslv2_la_LIBADD = @REDLAND_LIBS@