summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-10-06 14:08:11 -0400
committerDavid Robillard <d@drobilla.net>2024-10-06 14:08:31 -0400
commit307e343175d31179372098b21859fb6692d9fe43 (patch)
treec1bc5c51b3439199b7e7bd5bdf425788655bd267 /test/meson.build
parenta0fc1aef1fe9065ecabff51647aab036db244959 (diff)
downloadlilv-307e343175d31179372098b21859fb6692d9fe43.tar.gz
lilv-307e343175d31179372098b21859fb6692d9fe43.tar.bz2
lilv-307e343175d31179372098b21859fb6692d9fe43.zip
Relocate lint test definitions
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build42
1 files changed, 21 insertions, 21 deletions
diff --git a/test/meson.build b/test/meson.build
index 1815846..4ab5627 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -1,27 +1,6 @@
# Copyright 2020-2022 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
-####################
-# Project Metadata #
-####################
-
-if get_option('lint')
- if not meson.is_subproject()
- # Check release metadata
- autoship = find_program('autoship', required: false)
- if autoship.found()
- test('autoship', autoship, args: ['test', lilv_src_root], suite: 'data')
- endif
- endif
-
- # Check licensing metadata
- reuse = find_program('reuse', required: false)
- if reuse.found()
- reuse_args = ['--root', lilv_src_root, 'lint']
- test('REUSE', reuse, args: reuse_args, suite: 'data')
- endif
-endif
-
##############
# Test Setup #
##############
@@ -109,3 +88,24 @@ foreach unit : unit_tests
suite: 'unit',
)
endforeach
+
+########
+# Lint #
+########
+
+if get_option('lint')
+ if not meson.is_subproject()
+ # Check release metadata
+ autoship = find_program('autoship', required: false)
+ if autoship.found()
+ test('autoship', autoship, args: ['test', lilv_src_root], suite: 'data')
+ endif
+ endif
+
+ # Check licensing metadata
+ reuse = find_program('reuse', required: false)
+ if reuse.found()
+ reuse_args = ['--root', lilv_src_root, 'lint']
+ test('REUSE', reuse, args: reuse_args, suite: 'data')
+ endif
+endif