summaryrefslogtreecommitdiffstats
path: root/doc/xml/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/xml/meson.build')
-rw-r--r--doc/xml/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/doc/xml/meson.build b/doc/xml/meson.build
new file mode 100644
index 0000000..dc234f3
--- /dev/null
+++ b/doc/xml/meson.build
@@ -0,0 +1,21 @@
+# Copyright 2021-2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+doxygen = find_program('doxygen')
+
+config = configuration_data()
+config.set('LILV_SRCDIR', lilv_src_root)
+config.set('DOX_OUTPUT', meson.current_build_dir() / '..')
+
+c_doxyfile = configure_file(
+ configuration: config,
+ input: files('../Doxyfile.in'),
+ output: 'Doxyfile',
+)
+
+c_index_xml = custom_target(
+ 'index.xml',
+ command: [doxygen, '@INPUT0@'],
+ input: [c_doxyfile] + c_headers,
+ output: 'index.xml',
+)