summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index aeb79bf..4920b23 100644
--- a/meson.build
+++ b/meson.build
@@ -20,10 +20,17 @@ versioned_name = 'lilv' + version_suffix
# Compilers and Flags #
#######################
-# Load build tools
+# Required tools
pkg = import('pkgconfig')
cc = meson.get_compiler('c')
+# Enable C++ support if bindings aren't disabled
+if not get_option('bindings_cpp').disabled()
+ if add_languages(['cpp'], native: false, required: false)
+ cpp = meson.get_compiler('cpp')
+ endif
+endif
+
# Set global warning flags
if get_option('strict') and not meson.is_subproject()
subdir('meson/warnings')