summaryrefslogtreecommitdiffstats
path: root/swig/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'swig/python/Makefile.am')
-rw-r--r--swig/python/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/swig/python/Makefile.am b/swig/python/Makefile.am
new file mode 100644
index 0000000..8a7afc7
--- /dev/null
+++ b/swig/python/Makefile.am
@@ -0,0 +1,12 @@
+EXTRA_DIST = lv2_list.py
+
+if WITH_PYTHON
+all:
+ swig -DPYTHON -Wall -python -I../.. -o slv2_python.c -oh slv2_python.h ../slv2.i
+ gcc -fPIC -shared -I../.. $(PYTHON_CPPFLAGS) $(PYTHON_EXTRA_LDFLAGS) \
+ $(PYTHON_EXTRA_LIBS) $(PYTHON_EXTRA_LDFLAGS) \
+ slv2_python.c ../../src/.libs/libslv2.so -o _slv2.so
+
+clean-local:
+ rm -f *.[ch] *.so *.o slv2.py
+endif