summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build35
1 files changed, 1 insertions, 34 deletions
diff --git a/test/meson.build b/test/meson.build
index 1780bab..e260f37 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -92,38 +92,5 @@ endforeach
########
if get_option('lint')
- if not meson.is_subproject()
- # Check release metadata
- autoship = find_program('autoship', required: false)
- if autoship.found()
- test('autoship', autoship, args: ['test', lilv_src_root], suite: 'data')
- endif
-
- # Check code with cppcheck
- cppcheck = find_program('cppcheck', required: false)
- if cppcheck.found()
- compdb_path = join_paths(lilv_build_root, 'compile_commands.json')
- suppress_path = join_paths(lilv_src_root, '.suppress.cppcheck')
- test(
- 'cppcheck',
- cppcheck,
- args: [
- '--enable=warning,style,performance,portability',
- '--error-exitcode=1',
- '--project=' + compdb_path,
- '--suppressions-list=' + suppress_path,
- '-DLILV_VERSION="\"@0@\""'.format(meson.project_version()),
- '-q',
- ],
- suite: 'code',
- )
- endif
- endif
-
- # Check licensing metadata
- reuse = find_program('reuse', required: false)
- if reuse.found()
- reuse_args = ['--root', lilv_src_root, 'lint']
- test('REUSE', reuse, args: reuse_args, suite: 'data')
- endif
+ subdir('lint')
endif