aboutsummaryrefslogtreecommitdiffstats
path: root/src/engine/machina/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-02-10 04:54:15 +0000
committerDavid Robillard <d@drobilla.net>2007-02-10 04:54:15 +0000
commit87c0a475bd76ca33883eeafc2a86bc89a84eec2f (patch)
treef33b2a91e312d46ccd095065e62043a6e5d7a687 /src/engine/machina/Makefile.am
parentb924ead0db7c09ee50d2d4eee487b844c5fb867b (diff)
downloadmachina-87c0a475bd76ca33883eeafc2a86bc89a84eec2f.tar.gz
machina-87c0a475bd76ca33883eeafc2a86bc89a84eec2f.tar.bz2
machina-87c0a475bd76ca33883eeafc2a86bc89a84eec2f.zip
Reorganization to make MIDI generic and abstract away driver functionality
(so actions are serializable and usable with many drivers). Partial commit, broken. git-svn-id: http://svn.drobilla.net/lad/machina@298 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/engine/machina/Makefile.am')
-rw-r--r--src/engine/machina/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/engine/machina/Makefile.am b/src/engine/machina/Makefile.am
index eca6f9b..ffcae1e 100644
--- a/src/engine/machina/Makefile.am
+++ b/src/engine/machina/Makefile.am
@@ -7,6 +7,7 @@ libmachinainclude_HEADERS = \
Machine.hpp \
Loader.hpp \
JackDriver.hpp \
- JackActions.hpp \
NodeFactory.hpp \
- JackNodeFactory.hpp
+ JackNodeFactory.hpp \
+ MidiAction.hpp \
+ MidiDriver.hpp