aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-06-09 14:34:20 +0000
committerDavid Robillard <d@drobilla.net>2006-06-09 14:34:20 +0000
commit1ad3c632e91211ae84bc738eebd8d4a8318707c9 (patch)
treeb060300cf35069b227851f62f0957edb9006e989 /src/Makefile.am
Added omins
git-svn-id: http://svn.drobilla.net/lad/omins@8 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..55aeb32
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,40 @@
+AM_LDFLAGS = -module -avoidversion -Wc,-nostartfiles
+
+plugindir = @ladspadir@
+
+plugin_LTLIBRARIES = \
+ hz_voct_4200.la \
+ range_trans_4210.la \
+ formant_filter_4300.la \
+ adenv.la \
+ adenv_lvl.la \
+ dahdsr_fexp.la \
+ dahdsr_hexp.la \
+ prob_switch_2667.la \
+ signal_abs_2669.la \
+ slide_2741.la \
+ slew_limiter_2743.la \
+ waveguide_mesh_2670.la \
+ fast_crossfade_4410.la \
+ multiplexer_4420.la \
+ power_4400.la \
+ masher_4310.la \
+ sample_and_hold_4430.la \
+ comparison_4440.la
+
+# Stolen from swh-plugins, makes stupid libtool versions go away
+install-pluginLTLIBRARIES: $(plugin_LTLIBRARIES)
+ mkdir -p @ladspadir@
+ list='$(plugin_LTLIBRARIES)'; \
+ for file in $$list; do \
+ sofile=`basename $$file .la`.so; \
+ $(INSTALL_PROGRAM) .libs/$$sofile @ladspadir@; \
+ done
+
+uninstall-pluginLTLIBRARIES: $(plugin_LTLIBRARIES)
+ list='$(plugin_LTLIBRARIES)'; \
+ for file in $$list; do \
+ sofile=`basename $$file .la`.so; \
+ rm -f @ladspadir@/$$sofile; \
+ done
+