summaryrefslogtreecommitdiffstats
path: root/icons/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-19 09:54:48 -0400
committerDavid Robillard <d@drobilla.net>2022-07-20 10:35:05 -0400
commitc0ef025450cf1b7eec85ae8058e0a9e301e7cd16 (patch)
tree6914ea1a19f3cf656533b902cf823c4953bce5cb /icons/meson.build
parent4f33eb5ba4e2c116b9413282e18508815ea73966 (diff)
downloadpatchage-c0ef025450cf1b7eec85ae8058e0a9e301e7cd16.tar.gz
patchage-c0ef025450cf1b7eec85ae8058e0a9e301e7cd16.tar.bz2
patchage-c0ef025450cf1b7eec85ae8058e0a9e301e7cd16.zip
Switch to meson build system
Diffstat (limited to 'icons/meson.build')
-rw-r--r--icons/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/icons/meson.build b/icons/meson.build
new file mode 100644
index 0000000..30e78b1
--- /dev/null
+++ b/icons/meson.build
@@ -0,0 +1,34 @@
+# Copyright 2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR GPL-3.0-or-later
+
+svg_icon_sizes = [
+ '16x16',
+ '22x22',
+ '32x32',
+ '48x48',
+]
+
+png_icon_sizes = [
+ '16x16',
+ '22x22',
+ '24x24',
+ '32x32',
+ '48x48',
+ '128x128',
+ '256x256',
+]
+
+icons_dir = get_option('prefix') / get_option('datadir') / 'icons' / 'hicolor'
+
+install_data('scalable/patchage.svg',
+ install_dir: icons_dir / 'scalable' / 'apps')
+
+foreach size : svg_icon_sizes
+ install_data(files(size / 'patchage.svg'),
+ install_dir: icons_dir / size / 'apps')
+endforeach
+
+foreach size : png_icon_sizes
+ install_data(files(size / 'patchage.png'),
+ install_dir: icons_dir / size / 'apps')
+endforeach