aboutsummaryrefslogtreecommitdiffstats
path: root/doc/cpp/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-01-06 23:53:33 +0100
committerDavid Robillard <d@drobilla.net>2021-01-08 18:13:49 +0100
commit69d5d2adde1d13578a94e8b1934235987cf9b2bd (patch)
tree9720c044447bb12e6e714ac969ebb7b0daf87c5f /doc/cpp/meson.build
parent94e30b9c3c188dfdf4765f026872f95ea3cfdda2 (diff)
downloadpugl-69d5d2adde1d13578a94e8b1934235987cf9b2bd.tar.gz
pugl-69d5d2adde1d13578a94e8b1934235987cf9b2bd.tar.bz2
pugl-69d5d2adde1d13578a94e8b1934235987cf9b2bd.zip
Switch to Meson
Diffstat (limited to 'doc/cpp/meson.build')
-rw-r--r--doc/cpp/meson.build43
1 files changed, 43 insertions, 0 deletions
diff --git a/doc/cpp/meson.build b/doc/cpp/meson.build
new file mode 100644
index 0000000..d8bae11
--- /dev/null
+++ b/doc/cpp/meson.build
@@ -0,0 +1,43 @@
+config = configuration_data()
+config.set('PUGL_VERSION', meson.project_version())
+
+conf_py = configure_file(configuration: config,
+ input: '../conf.py.in',
+ output: 'conf.py')
+
+configure_file(copy: true, input: '../deployment.rst', output: 'deployment.rst')
+configure_file(copy: true, input: '../summary.rst', output: 'summary.rst')
+
+cpp_rst_files = files(
+ 'index.rst',
+ 'overview.rst',
+ 'world.rst',
+ 'view.rst',
+ 'events.rst',
+ 'event-loop.rst',
+)
+
+foreach f : cpp_rst_files
+ configure_file(copy: true, input: f, output: '@PLAINNAME@')
+endforeach
+
+subdir('xml')
+subdir('api')
+
+docs = custom_target(
+ 'C++ API Documentation (singlehtml)',
+ command: [sphinx_build, '-M', 'singlehtml', 'doc/cpp/', 'doc/cpp/', '-E', '-q', '-t', 'singlehtml'],
+ input: [cpp_rst_files, cpp_pugl_rst, cpp_index_xml],
+ output: 'singlehtml',
+ build_by_default: true,
+ install: true,
+ install_dir: docdir / 'puglxx-0')
+
+docs = custom_target(
+ 'C++ API Documentation (html)',
+ command: [sphinx_build, '-M', 'html', 'doc/cpp/', 'doc/cpp/', '-E', '-q', '-t', 'html'],
+ input: [cpp_rst_files, cpp_pugl_rst, cpp_index_xml],
+ output: 'html',
+ build_by_default: true,
+ install: true,
+ install_dir: docdir / 'puglxx-0')