aboutsummaryrefslogtreecommitdiffstats
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2025-02-06 20:50:15 -0500
committerDavid Robillard <d@drobilla.net>2025-02-06 20:50:15 -0500
commit2c52c6ec921130bed612b96c2939207391d5237c (patch)
tree28bc533ed2c6932a803c2e77e96935fba30c8819 /examples/meson.build
parent86b30b3db30909c025b9c42a10078d64a66c813a (diff)
downloadpugl-2c52c6ec921130bed612b96c2939207391d5237c.tar.gz
pugl-2c52c6ec921130bed612b96c2939207391d5237c.tar.bz2
pugl-2c52c6ec921130bed612b96c2939207391d5237c.zip
Add option to disable C++ bindings
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 0c4f998..ef77e65 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,4 +1,4 @@
-# Copyright 2021-2023 David Robillard <d@drobilla.net>
+# Copyright 2021-2025 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
data_dir = get_option('prefix') / get_option('datadir') / 'pugl-0'
@@ -148,6 +148,10 @@ else
elif target == 'pugl_print_events'
dependencies += [pugl_stub_dep]
elif target == 'pugl_cpp_demo'
+ if not is_variable('puglpp_dep')
+ continue
+ endif
+
dependencies += [puglpp_dep]
endif
@@ -185,8 +189,13 @@ else
defines = []
if target == 'pugl_vulkan_cpp_demo'
+ if not is_variable('puglpp_dep')
+ continue
+ endif
+
source += ['file_utils.c']
defines += ['-D_POSIX_C_SOURCE=200809L']
+ dependencies += [puglpp_dep]
endif
executable(