aboutsummaryrefslogtreecommitdiffstats
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2025-01-21 09:02:23 -0500
committerDavid Robillard <d@drobilla.net>2025-01-21 09:16:18 -0500
commit6a74f3e00786d18835278e29000b3938104c6241 (patch)
tree0653d2bbaf37cd07efe31c944b91a643f579b393 /examples/meson.build
parentaf40bdc5f8a7ab829cd1f1bee0c89c278ae5116b (diff)
downloadpugl-6a74f3e00786d18835278e29000b3938104c6241.tar.gz
pugl-6a74f3e00786d18835278e29000b3938104c6241.tar.bz2
pugl-6a74f3e00786d18835278e29000b3938104c6241.zip
Fix warnings in clang build on Windows
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index aa04e80..0c4f998 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -61,6 +61,13 @@ if get_option('warning_level') == 'everything' and is_variable('cpp')
'-Wno-old-style-cast',
'-Wno-switch-enum',
]
+ if host_machine.system() == 'windows'
+ example_cpp_args += [
+ '-Wno-deprecated-declarations',
+ '-Wno-format-nonliteral',
+ '-Wno-nonportable-system-include-path',
+ ]
+ endif
elif cpp.get_id() == 'gcc'
example_cpp_args += [
'-Wno-effc++',