aboutsummaryrefslogtreecommitdiffstats
path: root/examples/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2025-02-07 15:34:54 -0500
committerDavid Robillard <d@drobilla.net>2025-02-07 15:34:54 -0500
commitda301d48c6d519fb2020573c6a501a0c43f9064c (patch)
treee0b861e2cc3fd31503342a007c21f98110d086f0 /examples/meson.build
parent914e9086ef45031903cec79b12b20065ae3cac96 (diff)
downloadpugl-da301d48c6d519fb2020573c6a501a0c43f9064c.tar.gz
pugl-da301d48c6d519fb2020573c6a501a0c43f9064c.tar.bz2
pugl-da301d48c6d519fb2020573c6a501a0c43f9064c.zip
Move test utilities to a separate subproject
Towards sorting out sloppy include directories, and avoiding upward-relative paths in includes. A subproject seems like overkill, but this is the only way I can think of that makes for a clean local dependency that doesn't rely on anything non-standard or trigger any linters.
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/examples/meson.build b/examples/meson.build
index ef77e65..8206a10 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -28,7 +28,6 @@ vulkan_examples = [
]
includes = include_directories(
- '..',
'../bindings/cpp/include',
'../include',
)
@@ -120,7 +119,7 @@ else
foreach example : stub_examples
source = [example]
target = example.split('.')[0]
- dependencies = [pugl_dep, pugl_stub_dep]
+ dependencies = [pugl_dep, pugl_stub_dep, puglutil_dep]
defines = []
executable(
@@ -138,7 +137,7 @@ else
foreach example : gl_examples
source = [example]
target = example.split('.')[0]
- dependencies = [pugl_dep, pugl_gl_dep]
+ dependencies = [pugl_dep, pugl_gl_dep, puglutil_dep]
defines = []
if target == 'pugl_shader_demo'
@@ -174,7 +173,7 @@ else
target,
example,
c_args: example_defines + example_c_args + cairo_args,
- dependencies: [pugl_dep, pugl_cairo_dep],
+ dependencies: [pugl_dep, pugl_cairo_dep, puglutil_dep],
include_directories: includes,
)
endforeach
@@ -185,7 +184,7 @@ else
foreach example : vulkan_examples
source = [example]
target = example.split('.')[0]
- dependencies = [dl_dep, pugl_vulkan_dep]
+ dependencies = [dl_dep, pugl_vulkan_dep, puglutil_dep]
defines = []
if target == 'pugl_vulkan_cpp_demo'