aboutsummaryrefslogtreecommitdiffstats
path: root/examples/pugl_cairo_demo.app/MacOS/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2025-02-07 15:34:54 -0500
committerDavid Robillard <d@drobilla.net>2025-02-07 15:34:54 -0500
commitda301d48c6d519fb2020573c6a501a0c43f9064c (patch)
treee0b861e2cc3fd31503342a007c21f98110d086f0 /examples/pugl_cairo_demo.app/MacOS/meson.build
parent914e9086ef45031903cec79b12b20065ae3cac96 (diff)
downloadpugl-da301d48c6d519fb2020573c6a501a0c43f9064c.tar.gz
pugl-da301d48c6d519fb2020573c6a501a0c43f9064c.tar.bz2
pugl-da301d48c6d519fb2020573c6a501a0c43f9064c.zip
Move test utilities to a separate subproject
Towards sorting out sloppy include directories, and avoiding upward-relative paths in includes. A subproject seems like overkill, but this is the only way I can think of that makes for a clean local dependency that doesn't rely on anything non-standard or trigger any linters.
Diffstat (limited to 'examples/pugl_cairo_demo.app/MacOS/meson.build')
-rw-r--r--examples/pugl_cairo_demo.app/MacOS/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/pugl_cairo_demo.app/MacOS/meson.build b/examples/pugl_cairo_demo.app/MacOS/meson.build
index 18e1fcf..66221c7 100644
--- a/examples/pugl_cairo_demo.app/MacOS/meson.build
+++ b/examples/pugl_cairo_demo.app/MacOS/meson.build
@@ -6,6 +6,6 @@ executable(
['../../pugl_cairo_demo.c'],
c_args: example_defines + example_c_args + cairo_args,
cpp_args: example_defines + example_cpp_args,
- dependencies: [pugl_dep, pugl_cairo_dep],
+ dependencies: [pugl_dep, pugl_cairo_dep, puglutil_dep],
include_directories: include_directories('../../..'),
)