aboutsummaryrefslogtreecommitdiffstats
path: root/include/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-27 12:44:32 -0400
committerDavid Robillard <d@drobilla.net>2023-05-27 12:44:32 -0400
commit5424d37e388fbc68343d05acffaed29b7698dd9c (patch)
tree791d432e2838aedea2d95e8330e2794dce7c7c61 /include/meson.build
parent6514fbd3fd8e72950d0867f2ab1ce14dc44b0371 (diff)
downloadpugl-5424d37e388fbc68343d05acffaed29b7698dd9c.tar.gz
pugl-5424d37e388fbc68343d05acffaed29b7698dd9c.tar.bz2
pugl-5424d37e388fbc68343d05acffaed29b7698dd9c.zip
Use files() for headers in meson
Diffstat (limited to 'include/meson.build')
-rw-r--r--include/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/include/meson.build b/include/meson.build
index 00d4aed..20b056f 100644
--- a/include/meson.build
+++ b/include/meson.build
@@ -1,7 +1,7 @@
# Copyright 2021-2023 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
-c_headers = [
+c_headers = files(
'pugl/attributes.h',
'pugl/pugl.h',
@@ -10,8 +10,6 @@ c_headers = [
'pugl/glu.h',
'pugl/stub.h',
'pugl/vulkan.h',
-]
-
-c_header_files = files(c_headers)
+)
install_headers(c_headers, subdir: versioned_name / 'pugl')