aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-04-21 18:24:47 -0400
committerDavid Robillard <d@drobilla.net>2022-04-21 18:24:47 -0400
commit1f33fca3bcf2f7f329f9ba46b2c19f785e00ec98 (patch)
tree093737fd0a19933d603f4b7390fd5c1d2b3ce93b /meson.build
parenta8d612fd153451c58a5b62237dee82580bdc2676 (diff)
downloadpugl-1f33fca3bcf2f7f329f9ba46b2c19f785e00ec98.tar.gz
pugl-1f33fca3bcf2f7f329f9ba46b2c19f785e00ec98.tar.bz2
pugl-1f33fca3bcf2f7f329f9ba46b2c19f785e00ec98.zip
Fix MacOS build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b465ca1..c135329 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,12 @@ if get_option('strict')
'-Wno-switch-default',
'-Wno-switch-enum',
]
+
+ if host_machine.system() == 'darwin'
+ c_warnings += [
+ '-Wno-poison-system-directories',
+ ]
+ endif
elif cc.get_id() == 'gcc'
c_warnings += [
'-Wno-bad-function-cast',