aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-01-09 23:32:41 +0100
committerDavid Robillard <d@drobilla.net>2021-01-09 23:34:15 +0100
commit2630610bd4a2bab84d6fb89b8f18c87dc9f4c73b (patch)
tree92952ea4d8f7be98a75316ddf167a6b2544fca06 /meson.build
parent69d5d2adde1d13578a94e8b1934235987cf9b2bd (diff)
downloadpugl-2630610bd4a2bab84d6fb89b8f18c87dc9f4c73b.tar.gz
pugl-2630610bd4a2bab84d6fb89b8f18c87dc9f4c73b.tar.bz2
pugl-2630610bd4a2bab84d6fb89b8f18c87dc9f4c73b.zip
Supress windows warning about exceptions
Shame to turn this off, but I don't know how to avoid it as MSVC apparently can't figure out that vkGetInstanceProcAddr is a C function that doesn't throw.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 977f685..cadbf58 100644
--- a/meson.build
+++ b/meson.build
@@ -124,6 +124,7 @@ if get_option('strict')
'/wd4996', # function or variable may be unsafe
'/wd5026', # move constructor implicitly deleted
'/wd5027', # move assignment operator implicitly deleted
+ '/wd5039', # potentially throwing function passed to C
'/wd5045', # will insert Spectre mitigation for memory load
]
endif