aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-05-03 11:53:40 -0400
committerDavid Robillard <d@drobilla.net>2023-05-03 11:58:03 -0400
commit83c02756c8f48fc54c6e2cf96edb9245d891396a (patch)
treef73f3bc081caf7cf6b9efb5082fcf88c2257f6dd /meson.build
parent1a2160b236c06275214f36075dc4e8f05d2ecc64 (diff)
downloadpugl-83c02756c8f48fc54c6e2cf96edb9245d891396a.tar.gz
pugl-83c02756c8f48fc54c6e2cf96edb9245d891396a.tar.bz2
pugl-83c02756c8f48fc54c6e2cf96edb9245d891396a.zip
Replace strict option with new meson warning level
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 2 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index d15ba73..bd6894d 100644
--- a/meson.build
+++ b/meson.build
@@ -41,11 +41,8 @@ if host_machine.system() == 'darwin'
objcc = meson.get_compiler('objc')
endif
-# Set global ultra-strict warnings for developers if enabled
-if get_option('strict')
- subdir('meson/warnings')
- subdir('meson/suppressions')
-endif
+# Set global warning suppressions
+subdir('meson/suppressions')
# Disable deprecated API which is not used by tests or examples
add_project_arguments(