aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2025-01-21 15:15:02 -0500
committerDavid Robillard <d@drobilla.net>2025-01-21 16:24:17 -0500
commit90e05c940a4f99548d982b6976ba9aff8e6bdd8f (patch)
tree73e8a918dbe6ac5eebc7f76d087433aa3af404bb /meson.build
parentf2e36b35f48081d3fbe4001a868fab478d852d46 (diff)
downloadpugl-90e05c940a4f99548d982b6976ba9aff8e6bdd8f.tar.gz
pugl-90e05c940a4f99548d982b6976ba9aff8e6bdd8f.tar.bz2
pugl-90e05c940a4f99548d982b6976ba9aff8e6bdd8f.zip
Support building for Windows with or without UNICODE
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 78c6d7c..ec58fb8 100644
--- a/meson.build
+++ b/meson.build
@@ -156,6 +156,10 @@ elif host_machine.system() == 'windows'
]
endif
+ if not get_option('win_wchar').disabled()
+ win_args += ['-DUNICODE', '-D_UNICODE']
+ endif
+
add_project_arguments(win_args, language: ['c', 'cpp'])
user32_dep = cc.find_library('user32')